What’s Vulnerable › Vulnerabilities
CVE-2021-24798: WP Header Images < 2.0.1 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Header Images WordPress plugin before 2.0.1 does not sanitise and escape the t parameter before outputting it back in the plugin's settings page, leading to a Reflected Cross-Site Scripting issue
Affected products
- WP Header Images: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: WP Header Images 2.0.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/58c9a007-42db-4142-b096-0b9ba8850f87
- https://wpscan.com/vulnerability/58c9a007-42db-4142-b096-0b9ba8850f87
Get alerted when CVE-2021-24798 or the next vulnerability affects your stack