What’s Vulnerable › Vulnerabilities
CVE-2021-24799: Far Future Expiry Header < 1.5 - Plugin's Settings Update via CSRF
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-01 · updated 2026-06-17
- Weakness: CWE-352
Description
The Far Future Expiry Header WordPress plugin before 1.5 does not have CSRF check when saving its settings, which could allow attackers to make a logged in admin change them via a CSRF attack.
Affected products
- Far Future Expiry Header: before 1.5 — fixed in 1.5
How to fix
Upgrade to a fixed version: Far Future Expiry Header 1.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6010ce4e-3e46-4cc1-96d8-560b30b605ed
- https://wpscan.com/vulnerability/6010ce4e-3e46-4cc1-96d8-560b30b605ed
Get alerted when CVE-2021-24799 or the next vulnerability affects your stack