What’s Vulnerable › Vulnerabilities
CVE-2021-24802: Colorful Categories < 2.0.15 - Arbitrary Colors Update via CSRF
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-17 · updated 2026-06-17
- Weakness: CWE-352
Description
The Colorful Categories WordPress plugin before 2.0.15 does not enforce nonce checks which could allow attackers to make a logged in admin or editor change taxonomy colors via a CSRF attack
Affected products
- Colorful Categories: before 2.0.15 — fixed in 2.0.15
How to fix
Upgrade to a fixed version: Colorful Categories 2.0.15. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d92db61f-341c-4f3f-b962-326194ddbd1e
- https://wpscan.com/vulnerability/d92db61f-341c-4f3f-b962-326194ddbd1e
Get alerted when CVE-2021-24802 or the next vulnerability affects your stack