What’s Vulnerable › Vulnerabilities
CVE-2021-24804: Simple JWT Login < 3.2.1 - Arbitrary Settings Update to Site Takeover via CSRF
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-17 · updated 2026-06-17
- Weakness: CWE-352
Description
The Simple JWT Login WordPress plugin before 3.2.1 does not have nonce checks when saving its settings, allowing attackers to make a logged in admin changed them. Settings such as HMAC verification secret, account registering and default user roles can be updated, which could result in site takeover.
Affected products
- Simple JWT Login: before 3.2.1 — fixed in 3.2.1
How to fix
Upgrade to a fixed version: Simple JWT Login 3.2.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6f015e8e-462b-4ef7-a9a1-bb91e7d28e37
- https://wpscan.com/vulnerability/6f015e8e-462b-4ef7-a9a1-bb91e7d28e37
Get alerted when CVE-2021-24804 or the next vulnerability affects your stack