What’s Vulnerable › Vulnerabilities
CVE-2021-24806: wpDiscuz < 7.3.4 - Arbitrary Comment Addition/Edition/Deletion via CSRF
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-08 · updated 2026-06-17
- Weakness: CWE-352
Description
The wpDiscuz WordPress plugin before 7.3.4 does check for CSRF when adding, editing and deleting comments, which could allow attacker to make logged in users such as admin edit and delete arbitrary comment, or the user who made the comment to edit it via a CSRF attack. Attackers could also make logged in users post arbitrary comment.
Affected products
- gVectors wpDiscuz: before 7.3.4 — fixed in 7.3.4
How to fix
Upgrade to a fixed version: gVectors wpDiscuz 7.3.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2746101e-e993-42b9-bd6f-dfd5544fa3fe
- https://wpscan.com/vulnerability/2746101e-e993-42b9-bd6f-dfd5544fa3fe
Get alerted when CVE-2021-24806 or the next vulnerability affects your stack