What’s Vulnerable › Vulnerabilities
CVE-2021-24807: Support Board < 3.3.5 - Agent+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The Support Board WordPress plugin before 3.3.5 allows Authenticated (Agent+) users to perform Cross-Site Scripting attacks by placing a payload in the notes field, when an administrator or any authenticated user go to the chat the XSS will be automatically executed.
Affected products
- Schiocco Support Board: before 3.3.5 — fixed in 3.3.5
How to fix
Upgrade to a fixed version: Schiocco Support Board 3.3.5. Check the vendor advisory for mitigations.
References
- https://github.com/itsjeffersonli/CVE-2021-24807
- https://medium.com/%40lijohnjefferson/cve-2021-24807-6bc22af2a444
- https://wpscan.com/vulnerability/19d101aa-4b60-4db4-a33b-86c826b288b0
- https://github.com/itsjeffersonli/CVE-2021-24807
- https://medium.com/%40lijohnjefferson/cve-2021-24807-6bc22af2a444
- https://wpscan.com/vulnerability/19d101aa-4b60-4db4-a33b-86c826b288b0
Get alerted when CVE-2021-24807 or the next vulnerability affects your stack