What’s Vulnerable › Vulnerabilities
CVE-2021-24810: WP Event Manager < 3.1.23 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Event Manager WordPress plugin before 3.1.23 does not escape some of its Field Editor settings when outputting them, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- wpeventmanager WP Event Manager – Events Calendar, Registrations, Sell Tickets with WooCommerce: before 3.1.23 — fixed in 3.1.23
How to fix
Upgrade to a fixed version: wpeventmanager WP Event Manager – Events Calendar, Registrations, Sell Tickets with WooCommerce 3.1.23. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/94670822-0251-4e77-8d7f-b47aa7232e52
- https://wpscan.com/vulnerability/94670822-0251-4e77-8d7f-b47aa7232e52
Get alerted when CVE-2021-24810 or the next vulnerability affects your stack