What’s Vulnerable › Vulnerabilities
CVE-2021-24811: Shop Page WP < 1.2.8 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Shop Page WP WordPress plugin before 1.2.8 does not sanitise and escape some of the Product fields, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- Shop Page WP: before 1.2.8 — fixed in 1.2.8
How to fix
Upgrade to a fixed version: Shop Page WP 1.2.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/000e65f1-89cd-4dd5-a09d-5febd9fdfbdb
- https://wpscan.com/vulnerability/000e65f1-89cd-4dd5-a09d-5febd9fdfbdb
Get alerted when CVE-2021-24811 or the next vulnerability affects your stack