What’s Vulnerable › Vulnerabilities
CVE-2021-24812: BetterLinks < 1.2.6 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The BetterLinks WordPress plugin before 1.2.6 does not sanitise and escape some of imported link fields, which could lead to Stored Cross-Site Scripting issues when an admin import a malicious CSV.
Affected products
- WPDeveloper BetterLinks: before 1.2.6 — fixed in 1.2.6
How to fix
Upgrade to a fixed version: WPDeveloper BetterLinks 1.2.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6bc8fff1-ff10-4175-8a46-563f0f26f96a
- https://wpscan.com/vulnerability/6bc8fff1-ff10-4175-8a46-563f0f26f96a
Get alerted when CVE-2021-24812 or the next vulnerability affects your stack