What’s Vulnerable › Vulnerabilities
CVE-2021-24813: Events Made Easy < 2.2.24 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Events Made Easy WordPress plugin before 2.2.24 does not sanitise and escape Custom Field Names, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- Events Made Easy: before 2.2.24 — fixed in 2.2.24
How to fix
Upgrade to a fixed version: Events Made Easy 2.2.24. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2607749/
- https://wpscan.com/vulnerability/a1fe0783-7a88-4d75-967f-cef970b73752
- https://plugins.trac.wordpress.org/changeset/2607749/
- https://wpscan.com/vulnerability/a1fe0783-7a88-4d75-967f-cef970b73752
Get alerted when CVE-2021-24813 or the next vulnerability affects your stack