What’s Vulnerable › Vulnerabilities
CVE-2021-24821: Cost Calculator < 1.6 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The Cost Calculator WordPress plugin before 1.6 allows users with a role as low as Contributor to perform Stored Cross-Site Scripting attacks via the Description fields of a Cost Calculator > Price Settings (which gets injected on the edit page as well as any page that embeds the calculator using the shortcode), as well as the Text Preview field of a Project (injected on the edit project page)
Affected products
- Cost Calculator: before 1.6 — fixed in 1.6
How to fix
Upgrade to a fixed version: Cost Calculator 1.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/f0915b66-0b99-4aeb-9fba-759cafaeb0cb
- https://wpscan.com/vulnerability/f0915b66-0b99-4aeb-9fba-759cafaeb0cb
Get alerted when CVE-2021-24821 or the next vulnerability affects your stack