What’s Vulnerable › Vulnerabilities
CVE-2021-24822: Stylish Cost Calculator < 7.04 - Subscriber+ Unauthorised AJAX Calls to Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Stylish Cost Calculator WordPress plugin before 7.0.4 does not have any authorisation and CSRF checks on some of its AJAX actions (available to authenticated users), which could allow any authenticated users, such as subscriber to call them, and perform Stored Cross-Site Scripting attacks against logged in admin, as well as frontend users due to the lack of sanitisation and escaping in some parameters
Affected products
- Stylish Cost Calculator Premium: before 7.0.4 — fixed in 7.0.4
How to fix
Upgrade to a fixed version: Stylish Cost Calculator Premium 7.0.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/db84a782-d4c8-4abf-99ea-ea672a9b806e
- https://wpscan.com/vulnerability/db84a782-d4c8-4abf-99ea-ea672a9b806e
Get alerted when CVE-2021-24822 or the next vulnerability affects your stack