What’s Vulnerable › Vulnerabilities
CVE-2021-24825: Custom Content Shortcode < 4.0.2 - Authenticated Arbitrary File Access / LFI
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-07 · updated 2026-06-17
- Weakness: CWE-345
Description
The Custom Content Shortcode WordPress plugin before 4.0.2 does not validate the data passed to its load shortcode, which could allow Contributor+ (v < 4.0.1) or Admin+ (v < 4.0.2) users to display arbitrary files from the filesystem (such as logs, .htaccess etc), as well as perform Local File Inclusion attacks as PHP files will be executed. Please note that such attack is still possible by admin+ in single site blogs by default (but won't be when either the unfiltered_html or file_edit is disallowed)
Affected products
- Custom Content Shortcode: before 4.0.2 — fixed in 4.0.2
How to fix
Upgrade to a fixed version: Custom Content Shortcode 4.0.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/be9d6f82-c972-459a-bacf-65b3dfb11a09
- https://wpscan.com/vulnerability/be9d6f82-c972-459a-bacf-65b3dfb11a09
Get alerted when CVE-2021-24825 or the next vulnerability affects your stack