What’s Vulnerable › Vulnerabilities
CVE-2021-24826: Custom Content Shortcode < 4.0.2 - Authenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The Custom Content Shortcode WordPress plugin before 4.0.2 does not escape custom fields before outputting them, which could allow Contributor+ (v < 4.0.1) or Admin+ (v < 4.0.2) users to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed. Please note that such attack is still possible by admin+ in single site blogs by default (but won't be when the unfiltered_html is disallowed)
Affected products
- Custom Content Shortcode: before 4.0.2 — fixed in 4.0.2
How to fix
Upgrade to a fixed version: Custom Content Shortcode 4.0.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e247d78a-7243-486c-a017-7471a8dcb800
- https://wpscan.com/vulnerability/e247d78a-7243-486c-a017-7471a8dcb800
Get alerted when CVE-2021-24826 or the next vulnerability affects your stack