What’s Vulnerable › Vulnerabilities
CVE-2021-24828: Mortgage Calculator / Loan Calculator < 1.5.17 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-03 · updated 2026-06-17
- Weakness: CWE-79
Description
The Mortgage Calculator / Loan Calculator WordPress plugin before 1.5.17 does not escape the some of the attributes of its mlcalc shortcode before outputting them, which could allow users with a role as low as contributor to perform Cross-Site Scripting attacks
Affected products
- Mortgage Calculator / Loan Calculator: before 1.5.17 — fixed in 1.5.17
How to fix
Upgrade to a fixed version: Mortgage Calculator / Loan Calculator 1.5.17. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6f9d1ee5-7ed7-4304-96a2-611b2f0081d2
- https://wpscan.com/vulnerability/6f9d1ee5-7ed7-4304-96a2-611b2f0081d2
Get alerted when CVE-2021-24828 or the next vulnerability affects your stack