What’s Vulnerable › Vulnerabilities
CVE-2021-24830: Advanced Access Manager < 6.8.0 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The Advanced Access Manager WordPress plugin before 6.8.0 does not escape some of its settings when outputting them, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- AAM Advanced Access Manager – Restricted Content, Users & Roles, Enhanced Security and More: before 6.8.0 — fixed in 6.8.0
How to fix
Upgrade to a fixed version: AAM Advanced Access Manager – Restricted Content, Users & Roles, Enhanced Security and More 6.8.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2616161/
- https://wpscan.com/vulnerability/1c46373b-d43d-4d18-b0ae-3711fb0be0f9
- https://plugins.trac.wordpress.org/changeset/2616161/
- https://wpscan.com/vulnerability/1c46373b-d43d-4d18-b0ae-3711fb0be0f9
Get alerted when CVE-2021-24830 or the next vulnerability affects your stack