What’s Vulnerable › Vulnerabilities
CVE-2021-24833: YOP Poll < 6.3.1 - Author+ Stored Cross-Site Scripting via Preview Module
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The YOP Poll WordPress plugin before 6.3.1 is affected by a stored Cross-Site Scripting vulnerability, which exists in the Admin preview module where a user with a role as low as author is allowed to execute arbitrary script code within the context of the application. This vulnerability is due to insufficient validation of question and answer text parameters in Create Poll module.
Affected products
- YOP Poll: before 6.3.1 — fixed in 6.3.1
How to fix
Upgrade to a fixed version: YOP Poll 6.3.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2605368
- https://wpscan.com/vulnerability/7cb39087-fbab-463d-9592-003e3fca6d34
- https://www.fortiguard.com/zeroday/FG-VD-21-052
- https://plugins.trac.wordpress.org/changeset/2605368
- https://wpscan.com/vulnerability/7cb39087-fbab-463d-9592-003e3fca6d34
- https://www.fortiguard.com/zeroday/FG-VD-21-052
Get alerted when CVE-2021-24833 or the next vulnerability affects your stack