What’s Vulnerable › Vulnerabilities
CVE-2021-24838: AnyComment < 0.3.5 - Open Redirect
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-01-17 · updated 2026-06-17
- Weakness: CWE-601
Description
The AnyComment WordPress plugin before 0.3.5 has an API endpoint which passes user input via the redirect parameter to the wp_redirect() function without being validated first, leading to an Open Redirect issue, which according to the vendor, is a feature.
Affected products
- AnyComment: before 0.3.5 — fixed in 0.3.5
How to fix
Upgrade to a fixed version: AnyComment 0.3.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/562e81ad-7422-4437-a5b4-fcab9379db82
- https://wpscan.com/vulnerability/562e81ad-7422-4437-a5b4-fcab9379db82
Get alerted when CVE-2021-24838 or the next vulnerability affects your stack