What’s Vulnerable › Vulnerabilities
CVE-2021-24839: SupportCandy < 2.2.5 - Unauthenticated Arbitrary Ticket Deletion
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-07 · updated 2026-06-17
- Weakness: CWE-862
Description
The SupportCandy WordPress plugin before 2.2.5 does not have authorisation and CSRF checks in its wpsc_tickets AJAX action, which could allow unauthenticated users to call it and delete arbitrary tickets via the set_delete_permanently_bulk_ticket setting_action. Other actions may be affected as well.
Affected products
- SupportCandy: before 2.2.5 — fixed in 2.2.5
How to fix
Upgrade to a fixed version: SupportCandy 2.2.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5e6e63c2-2675-4b8d-9b94-c16c525a1a0e
- https://wpscan.com/vulnerability/5e6e63c2-2675-4b8d-9b94-c16c525a1a0e
Get alerted when CVE-2021-24839 or the next vulnerability affects your stack