What’s Vulnerable › Vulnerabilities
CVE-2021-24841: Helpful < 4.4.59 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The Helpful WordPress plugin before 4.4.59 does not sanitise and escape some of its settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- Helpful: before 4.4.59 — fixed in 4.4.59
How to fix
Upgrade to a fixed version: Helpful 4.4.59. Check the vendor advisory for mitigations.
References
- https://mikadmin.fr/tech/XSS-Stored-Helpful-5b10bc7f40ab319f9797eb4abad4f420660.pdf
- https://wpscan.com/vulnerability/55d11acf-8c47-40da-be47-24f74fd7566e
- https://mikadmin.fr/tech/XSS-Stored-Helpful-5b10bc7f40ab319f9797eb4abad4f420660.pdf
- https://wpscan.com/vulnerability/55d11acf-8c47-40da-be47-24f74fd7566e
Get alerted when CVE-2021-24841 or the next vulnerability affects your stack