What’s Vulnerable › Vulnerabilities
CVE-2021-24848: Mediamatic < 2.8.1 - Subscriber+ SQL Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-13 · updated 2026-06-17
- Weakness: CWE-89
Description
The mediamaticAjaxRenameCategory AJAX action of the Mediamatic WordPress plugin before 2.8.1, available to any authenticated user, does not sanitise the categoryID parameter before using it in a SQL statement, leading to an SQL injection
Affected products
- Plugincraft Mediamatic – Media Library Folders: before 2.8.1 — fixed in 2.8.1
How to fix
Upgrade to a fixed version: Plugincraft Mediamatic – Media Library Folders 2.8.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/156d4faf-7d34-4d9f-a654-9064d4eb3aea
- https://wpscan.com/vulnerability/156d4faf-7d34-4d9f-a654-9064d4eb3aea
Get alerted when CVE-2021-24848 or the next vulnerability affects your stack