What’s Vulnerable › Vulnerabilities
CVE-2021-24850: Insert Pages < 3.7.0 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The Insert Pages WordPress plugin before 3.7.0 adds a shortcode that prints out other pages' content and custom fields. It can be used by users with a role as low as Contributor to perform Cross-Site Scripting attacks by storing the payload/s in another post's custom fields.
Affected products
- Insert Pages: before 3.7.0 — fixed in 3.7.0
How to fix
Upgrade to a fixed version: Insert Pages 3.7.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2d6f9be0-b9fd-48e5-bd68-94eeb3822c0a
- https://wpscan.com/vulnerability/2d6f9be0-b9fd-48e5-bd68-94eeb3822c0a
Get alerted when CVE-2021-24850 or the next vulnerability affects your stack