What’s Vulnerable › Vulnerabilities
CVE-2021-24855: Display Post Metadata < 1.5.0 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Display Post Metadata WordPress plugin before 1.5.0 adds a shortcode to print out custom fields, however their content is not sanitised or escaped which could allow users with a role as low as Contributor to perform Cross-Site Scripting attacks
Affected products
- Display Post Metadata: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: Display Post Metadata 1.5.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/49328498-d3a0-4d27-8a52-24054b5e42f3
- https://wpscan.com/vulnerability/49328498-d3a0-4d27-8a52-24054b5e42f3
Get alerted when CVE-2021-24855 or the next vulnerability affects your stack