What’s Vulnerable › Vulnerabilities
CVE-2021-24864: WP Cloudy < 4.4.9 - Admin+ SQL Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-89
Description
The WP Cloudy, weather plugin WordPress plugin before 4.4.9 does not escape the post_id parameter before using it in a SQL statement in the admin dashboard, leading to a SQL Injection issue
Affected products
- WP Cloudy, weather plugin: before 4.4.9 — fixed in 4.4.9
How to fix
Upgrade to a fixed version: WP Cloudy, weather plugin 4.4.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2615400
- https://wpscan.com/vulnerability/e3b9ee9f-602d-4e9d-810c-e1e3ba604464
- https://plugins.trac.wordpress.org/changeset/2615400
- https://wpscan.com/vulnerability/e3b9ee9f-602d-4e9d-810c-e1e3ba604464
Get alerted when CVE-2021-24864 or the next vulnerability affects your stack