What’s Vulnerable › Vulnerabilities
CVE-2021-24870: WP Fastest Cache < 0.9.5 - CSRF to Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-16 · updated 2026-06-17
- Weakness: CWE-352
Description
The WP Fastest Cache WordPress plugin before 0.9.5 is lacking a CSRF check in its wpfc_save_cdn_integration AJAX action, and does not sanitise and escape some the options available via the action, which could allow attackers to make logged in high privilege users call it and set a Cross-Site Scripting payload
Affected products
- emrevona WP Fastest Cache – WordPress Cache Plugin: before 0.9.5 — fixed in 0.9.5
How to fix
Upgrade to a fixed version: emrevona WP Fastest Cache – WordPress Cache Plugin 0.9.5. Check the vendor advisory for mitigations.
References
- https://jetpack.com/2021/10/14/multiple-vulnerabilities-in-wp-fastest-cache-plugin/
- https://wpscan.com/vulnerability/48de63ab-2ef1-4469-8fc4-9346068bdf06/
- https://jetpack.com/2021/10/14/multiple-vulnerabilities-in-wp-fastest-cache-plugin/
- https://wpscan.com/vulnerability/48de63ab-2ef1-4469-8fc4-9346068bdf06/
Get alerted when CVE-2021-24870 or the next vulnerability affects your stack