What’s Vulnerable › Vulnerabilities
CVE-2021-24871: Get Custom Field Values < 4.0.1 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Get Custom Field Values WordPress plugin before 4.0.1 does not escape custom fields before outputting them in the page, which could allow users with a role as low as contributor to perform Cross-Site Scripting attacks
Affected products
- Get Custom Field Values: before 4.0.1 — fixed in 4.0.1
How to fix
Upgrade to a fixed version: Get Custom Field Values 4.0.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/28007c80-dc14-4987-a52c-f2a05cfe5905
- https://wpscan.com/vulnerability/28007c80-dc14-4987-a52c-f2a05cfe5905
Get alerted when CVE-2021-24871 or the next vulnerability affects your stack