What’s Vulnerable › Vulnerabilities
CVE-2021-24873: Tutor LMS < 1.9.11 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The Tutor LMS WordPress plugin before 1.9.11 does not sanitise and escape user input before outputting back in attributes in the Student Registration page, leading to a Reflected Cross-Site Scripting issue
Affected products
- themeum Tutor LMS – eLearning and online course solution: before 1.9.11 — fixed in 1.9.11
How to fix
Upgrade to a fixed version: themeum Tutor LMS – eLearning and online course solution 1.9.11. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2615802/tutor
- https://wpscan.com/vulnerability/19980b57-1954-4a29-b2c2-43eadf758ed3
- https://plugins.trac.wordpress.org/changeset/2615802/tutor
- https://wpscan.com/vulnerability/19980b57-1954-4a29-b2c2-43eadf758ed3
Get alerted when CVE-2021-24873 or the next vulnerability affects your stack