What’s Vulnerable › Vulnerabilities
CVE-2021-24878: SupportCandy < 2.2.7 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The SupportCandy WordPress plugin before 2.2.7 does not sanitise and escape the query string before outputting it back in pages with the [wpsc_create_ticket] shortcode embed, leading to a Reflected Cross-Site Scripting issue
Affected products
- SupportCandy: before 2.2.7 — fixed in 2.2.7
How to fix
Upgrade to a fixed version: SupportCandy 2.2.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d2f1fd60-5e5e-4e38-9559-ba2d14ae37bf
- https://wpscan.com/vulnerability/d2f1fd60-5e5e-4e38-9559-ba2d14ae37bf
Get alerted when CVE-2021-24878 or the next vulnerability affects your stack