What’s Vulnerable › Vulnerabilities
CVE-2021-24879: SupportCandy < 2.2.7 - CSRF to Cross-Site Scripting
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-07 · updated 2026-06-17
- Weakness: CWE-352
Description
The SupportCandy WordPress plugin before 2.2.7 does not have CSRF check in the wpsc_tickets AJAX action, nor has any sanitisation or escaping in some of the filter fields which could allow attackers to make a logged in user having access to the ticket lists dashboard set an arbitrary filter (stored in their cookies) with an XSS payload in it.
Affected products
- SupportCandy: before 2.2.7 — fixed in 2.2.7
How to fix
Upgrade to a fixed version: SupportCandy 2.2.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6dfb4f61-c8cb-40ad-812f-139482be0fb4
- https://wpscan.com/vulnerability/6dfb4f61-c8cb-40ad-812f-139482be0fb4
Get alerted when CVE-2021-24879 or the next vulnerability affects your stack