What’s Vulnerable › Vulnerabilities
CVE-2021-24880: SupportCandy < 2.2.7 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The SupportCandy WordPress plugin before 2.2.7 does not validate and escape the page attribute of its shortcode, which could allow users with a role as low as Contributor to perform Cross-Site Scripting attacks
Affected products
- SupportCandy: before 2.2.7 — fixed in 2.2.7
How to fix
Upgrade to a fixed version: SupportCandy 2.2.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/09226067-0289-4d4f-9450-6f2c2ba058a0
- https://wpscan.com/vulnerability/09226067-0289-4d4f-9450-6f2c2ba058a0
Get alerted when CVE-2021-24880 or the next vulnerability affects your stack