What’s Vulnerable › Vulnerabilities
CVE-2021-24882: Slideshow Gallery < 1.7.4 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The Slideshow Gallery WordPress plugin before 1.7.4 does not sanitise and escape the Slide "Title", "Description", and Gallery "Title" fields, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed
Affected products
- Tribulant Slideshow Gallery: before 1.7.4 — fixed in 1.7.4
How to fix
Upgrade to a fixed version: Tribulant Slideshow Gallery 1.7.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6d71816c-8267-4b84-9087-191fbb976e72
- https://wpscan.com/vulnerability/6d71816c-8267-4b84-9087-191fbb976e72
Get alerted when CVE-2021-24882 or the next vulnerability affects your stack