What’s Vulnerable › Vulnerabilities
CVE-2021-24883: Popup Anything < 2.0.4 - Contributor+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Popup Anything WordPress plugin before 2.0.4 does not escape the Link Text and Button Text fields of Popup, which could allow users with a role as low as Contributor to perform Cross-Site Scripting attacks
Affected products
- Popup Anything – A Marketing Popup and Lead Generation Conversions: before 2.0.4 — fixed in 2.0.4
How to fix
Upgrade to a fixed version: Popup Anything – A Marketing Popup and Lead Generation Conversions 2.0.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2610975
- https://wpscan.com/vulnerability/c5dd3812-ea20-4e05-a5d3-84830b452822
- https://www.fortiguard.com/zeroday/FG-VD-21-069
- https://plugins.trac.wordpress.org/changeset/2610975
- https://wpscan.com/vulnerability/c5dd3812-ea20-4e05-a5d3-84830b452822
- https://www.fortiguard.com/zeroday/FG-VD-21-069
Get alerted when CVE-2021-24883 or the next vulnerability affects your stack