What’s Vulnerable › Vulnerabilities
CVE-2021-24885: YOP Poll < 6.1.2 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The YOP Poll WordPress plugin before 6.1.2 does not escape the perpage parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting
Affected products
- Yop-Poll: before 6.1.2 — fixed in 6.1.2
How to fix
Upgrade to a fixed version: Yop-Poll 6.1.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2227747/
- https://wpscan.com/vulnerability/d0b312f8-8b16-45be-b5e5-bf9d4b3e9b1e
- https://plugins.trac.wordpress.org/changeset/2227747/
- https://wpscan.com/vulnerability/d0b312f8-8b16-45be-b5e5-bf9d4b3e9b1e
Get alerted when CVE-2021-24885 or the next vulnerability affects your stack