What’s Vulnerable › Vulnerabilities
CVE-2021-24888: ImageBoss < 3.0.6 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The ImageBoss WordPress plugin before 3.0.6 does not sanitise and escape its Source Name setting, which could allow high privilege users to perform Cross-Site Scripting attacks
Affected products
- ImageBoss – Images Up To 60% Smaller & CDN: before 3.0.6 — fixed in 3.0.6
How to fix
Upgrade to a fixed version: ImageBoss – Images Up To 60% Smaller & CDN 3.0.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/19bffa71-705c-42fc-b2ca-bf62fabb70a0
- https://wpscan.com/vulnerability/19bffa71-705c-42fc-b2ca-bf62fabb70a0
Get alerted when CVE-2021-24888 or the next vulnerability affects your stack