What’s Vulnerable › Vulnerabilities
CVE-2021-24890: Scripts Organizer < 3.0 - Unauthenticated Arbitrary File Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-26 · updated 2026-06-17
- Weakness: CWE-352
Description
The Scripts Organizer WordPress plugin before 3.0 does not have capability and CSRF checks in the saveScript AJAX action, available to both unauthenticated and authenticated users, and does not validate user input in any way, which could allow unauthenticated users to put arbitrary PHP code in a file
Affected products
- scripts-organizer: before 3.0 — fixed in 3.0
How to fix
Upgrade to a fixed version: scripts-organizer 3.0. Check the vendor advisory for mitigations.
References
- https://dplugins.com/products/scripts-organizer/
- https://wpscan.com/vulnerability/f3b450d2-84ce-4c13-ad6a-b60785dee7e7
- https://dplugins.com/products/scripts-organizer/
- https://wpscan.com/vulnerability/f3b450d2-84ce-4c13-ad6a-b60785dee7e7
Get alerted when CVE-2021-24890 or the next vulnerability affects your stack