What’s Vulnerable › Vulnerabilities
CVE-2021-24892: Advanced Forms < 1.6.9 - Subscriber+ Arbitrary User Email Address Update via IDOR
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-23 · updated 2026-06-17
- Weakness: CWE-639
Description
Insecure Direct Object Reference in edit function of Advanced Forms (Free & Pro) before 1.6.9 allows authenticated remote attacker to change arbitrary user's email address and request for reset password, which could lead to take over of WordPress's administrator account. To exploit this vulnerability, an attacker must register to obtain a valid WordPress's user and use such user to authenticate with WordPress in order to exploit the vulnerable edit function.
Affected products
- Advanced Forms Project Advanced Forms: before 1.6.9 — fixed in 1.6.9
How to fix
Upgrade to a fixed version: Advanced Forms Project Advanced Forms 1.6.9. Check the vendor advisory for mitigations.
References
- https://github.com/advancedforms/advanced-forms/commit/2ce3ab6985c3a909eefb01c562995bc6a994d3a2
- https://wpscan.com/vulnerability/364b0843-a990-4204-848a-60c928cc5bc0
- https://github.com/advancedforms/advanced-forms/commit/2ce3ab6985c3a909eefb01c562995bc6a994d3a2
- https://wpscan.com/vulnerability/364b0843-a990-4204-848a-60c928cc5bc0
Get alerted when CVE-2021-24892 or the next vulnerability affects your stack