What’s Vulnerable › Vulnerabilities
CVE-2021-24895: Cybersoldier < 1.7.0 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Cybersoldier WordPress plugin before 1.7.0 does not sanitise and escape the URL settings before outputting it in an attribute, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- Cybersoldier: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: Cybersoldier 1.7.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/be7bbf4f-6f6a-4a44-bf86-2f096351ae08
- https://wpscan.com/vulnerability/be7bbf4f-6f6a-4a44-bf86-2f096351ae08
Get alerted when CVE-2021-24895 or the next vulnerability affects your stack