What’s Vulnerable › Vulnerabilities
CVE-2021-24896: Caldera forms < 1.9.5 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Caldera Forms WordPress plugin before 1.9.5 does not sanitise and escape the Form Name before outputting it in attributes, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- Caldera Forms – More Than Contact Forms: before 1.9.5 — fixed in 1.9.5
How to fix
Upgrade to a fixed version: Caldera Forms – More Than Contact Forms 1.9.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2c469e8b-c761-460b-b31d-9219a43006ff
- https://wpscan.com/vulnerability/2c469e8b-c761-460b-b31d-9219a43006ff
Get alerted when CVE-2021-24896 or the next vulnerability affects your stack