What’s Vulnerable › Vulnerabilities
CVE-2021-24900: Ninja Tables < 4.1.8 - Admin+ Stored Cross-Site Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Ninja Tables WordPress plugin before 4.1.8 does not sanitise and escape some of its table fields, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- WPManageNinja LLC Ninja Tables: before 4.1.8 — fixed in 4.1.8
How to fix
Upgrade to a fixed version: WPManageNinja LLC Ninja Tables 4.1.8. Check the vendor advisory for mitigations.
References
- https://packetstormsecurity.com/files/164632/
- https://wpscan.com/vulnerability/213d7c08-a37c-49d0-a072-24db711da5ec
- https://packetstormsecurity.com/files/164632/
- https://wpscan.com/vulnerability/213d7c08-a37c-49d0-a072-24db711da5ec
Get alerted when CVE-2021-24900 or the next vulnerability affects your stack