What’s Vulnerable › Vulnerabilities
CVE-2021-24902: Typebot < 1.4.3 - Admin+ Stored Cross Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The Typebot | Build beautiful conversational forms WordPress plugin before 1.4.3 does not sanitise and escape the Publish ID setting, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- baptisteArno typebot.io: before 1.4.3 — fixed in 1.4.3
How to fix
Upgrade to a fixed version: baptisteArno typebot.io 1.4.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2bde2030-2dfe-4dd3-afc1-36f7031a91ea
- https://wpscan.com/vulnerability/2bde2030-2dfe-4dd3-afc1-36f7031a91ea
Get alerted when CVE-2021-24902 or the next vulnerability affects your stack