What’s Vulnerable › Vulnerabilities
CVE-2021-24904: Mortgage Calculators WP < 1.56 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Mortgage Calculators WP WordPress plugin before 1.56 does not implement any sanitisation on the color setting of the background of a calculator, which could allow high privilege users to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- Lenderd Mortgage Calculators WP: before 1.56 — fixed in 1.56
How to fix
Upgrade to a fixed version: Lenderd Mortgage Calculators WP 1.56. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/7b80f89b-e724-41c5-aa03-21d1eef50f21
- https://wpscan.com/vulnerability/7b80f89b-e724-41c5-aa03-21d1eef50f21
Get alerted when CVE-2021-24904 or the next vulnerability affects your stack