What’s Vulnerable › Vulnerabilities
CVE-2021-24907: Everest Forms < 1.8.0 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The Contact Form, Drag and Drop Form Builder for WordPress plugin before 1.8.0 does not escape the status parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting issue
Affected products
- wpeverest Everest Forms – Contact Form, Payment Form, Quiz, Survey & Custom Form Builder: before 1.8.0 — fixed in 1.8.0
How to fix
Upgrade to a fixed version: wpeverest Everest Forms – Contact Form, Payment Form, Quiz, Survey & Custom Form Builder 1.8.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/56dae1ae-d5d2-45d3-8991-db69cc47ddb7
- https://wpscan.com/vulnerability/56dae1ae-d5d2-45d3-8991-db69cc47ddb7
Get alerted when CVE-2021-24907 or the next vulnerability affects your stack