What’s Vulnerable › Vulnerabilities
CVE-2021-24910: Transposh WordPress Translation < 1.0.8 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The Transposh WordPress Translation WordPress plugin before 1.0.8 does not sanitise and escape the a parameter via an AJAX action (available to both unauthenticated and authenticated users when the curl library is installed) before outputting it back in the response, leading to a Reflected Cross-Site Scripting issue
Affected products
- Transposh WordPress Translation: before 1.0.8 — fixed in 1.0.8
How to fix
Upgrade to a fixed version: Transposh WordPress Translation 1.0.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b5cbebf4-5749-41a0-8be3-3333853fca17
- https://wpscan.com/vulnerability/b5cbebf4-5749-41a0-8be3-3333853fca17
Get alerted when CVE-2021-24910 or the next vulnerability affects your stack