What’s Vulnerable › Vulnerabilities
CVE-2021-24912: Transposh WordPress Translation < 1.0.8 - CSRF to Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The Transposh WordPress Translation WordPress plugin before 1.0.8 does not have CSRF check in its tp_translation AJAX action, which could allow attackers to make authorised users add a translation. Given the lack of sanitisation in the tk0 parameter, this could lead to a Stored Cross-Site Scripting issue which will be executed in the context of a logged in admin
Affected products
- Transposh WordPress Translation: before 1.0.8 — fixed in 1.0.8
How to fix
Upgrade to a fixed version: Transposh WordPress Translation 1.0.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/349483e2-3ab5-4573-bc03-b1ebab40584d
- https://wpscan.com/vulnerability/349483e2-3ab5-4573-bc03-b1ebab40584d
Get alerted when CVE-2021-24912 or the next vulnerability affects your stack