What’s Vulnerable › Vulnerabilities
CVE-2021-24917: WPS Hide Login < 1.9.1 - Protection Bypass with Referer-Header
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 72.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-06 · updated 2026-06-17
- Weakness: CWE-863
Description
The WPS Hide Login WordPress plugin before 1.9.1 has a bug which allows to get the secret login page by setting a random referer string and making a request to /wp-admin/options.php as an unauthenticated user.
Affected products
- tabrisrp WPS Hide Login: before 1.9.1 — fixed in 1.9.1
How to fix
Upgrade to a fixed version: tabrisrp WPS Hide Login 1.9.1. Check the vendor advisory for mitigations.
References
- https://wordpress.org/support/topic/bypass-security-issue/
- https://wpscan.com/vulnerability/15bb711a-7d70-4891-b7a2-c473e3e8b375
- https://wordpress.org/support/topic/bypass-security-issue/
- https://wpscan.com/vulnerability/15bb711a-7d70-4891-b7a2-c473e3e8b375
Get alerted when CVE-2021-24917 or the next vulnerability affects your stack