What’s Vulnerable › Vulnerabilities
CVE-2021-24918: Smash Balloon Social Post Feed < 4.0.1 - Subscriber+ Arbitrary Plugin Settings Update to Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Smash Balloon Social Post Feed WordPress plugin before 4.0.1 did not have any privilege or nonce validation before saving the plugin's setting. As a result, any logged-in user on a vulnerable site could update the settings and store rogue JavaScript on each of its posts and pages.
Affected products
- Smash Balloon Social Post Feed: before 4.0.1 — fixed in 4.0.1
How to fix
Upgrade to a fixed version: Smash Balloon Social Post Feed 4.0.1. Check the vendor advisory for mitigations.
References
- https://jetpack.com/2021/10/29/security-issues-patched-in-smash-balloon-social-post-feed-plugin/
- https://wpscan.com/vulnerability/5d252ad7-bf28-44f3-8cd0-c4fe05c48f35
- https://jetpack.com/2021/10/29/security-issues-patched-in-smash-balloon-social-post-feed-plugin/
- https://wpscan.com/vulnerability/5d252ad7-bf28-44f3-8cd0-c4fe05c48f35
Get alerted when CVE-2021-24918 or the next vulnerability affects your stack