What’s Vulnerable › Vulnerabilities
CVE-2021-24920: StatCounter < 2.0.7 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The StatCounter WordPress plugin before 2.0.7 does not sanitise and escape the Project ID and Secure Code settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Affected products
- StatCounter: before 2.0.7 — fixed in 2.0.7
How to fix
Upgrade to a fixed version: StatCounter 2.0.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2664933
- https://wpscan.com/vulnerability/b00b5037-8ce4-4f61-b2ce-33315b39454e
- https://plugins.trac.wordpress.org/changeset/2664933
- https://wpscan.com/vulnerability/b00b5037-8ce4-4f61-b2ce-33315b39454e
Get alerted when CVE-2021-24920 or the next vulnerability affects your stack