What’s Vulnerable › Vulnerabilities
CVE-2021-24921: Advanced Database Cleaner < 3.0.4 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The Advanced Database Cleaner WordPress plugin before 3.0.4 does not sanitise and escape $_GET keys and values before outputting them back in attributes, leading to Reflected Cross-Site Scripting issues
Affected products
- Advanced Database Cleaner: before 3.0.4 — fixed in 3.0.4
How to fix
Upgrade to a fixed version: Advanced Database Cleaner 3.0.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/43ab0997-4d15-4ff7-af41-7b528b0ba3c7
- https://wpscan.com/vulnerability/43ab0997-4d15-4ff7-af41-7b528b0ba3c7
Get alerted when CVE-2021-24921 or the next vulnerability affects your stack