What’s Vulnerable › Vulnerabilities
CVE-2021-24922: Pixel Cat Lite < 2.6.2 - CSRF to Stored Cross-Site Scripting
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-13 · updated 2026-06-17
- Weakness: CWE-352
Description
The Pixel Cat WordPress plugin before 2.6.2 does not have CSRF check when saving its settings, and did not sanitise as well as escape some of them, which could allow attacker to make a logged in admin change them and perform Cross-Site Scripting attacks
Affected products
- Pixel Cat – Conversion Pixel Manager: before 2.6.2 — fixed in 2.6.2
How to fix
Upgrade to a fixed version: Pixel Cat – Conversion Pixel Manager 2.6.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/399ffd65-f3c0-4fbe-a83a-2a620976aad2
- https://wpscan.com/vulnerability/399ffd65-f3c0-4fbe-a83a-2a620976aad2
Get alerted when CVE-2021-24922 or the next vulnerability affects your stack