What’s Vulnerable › Vulnerabilities
CVE-2021-24924: Email Log < 2.4.8 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Email Log WordPress plugin before 2.4.8 does not escape the d parameter before outputting it back in an attribute in the Log page, leading to a Reflected Cross-Site Scripting issue
Affected products
- Email Log: before 2.4.8 — fixed in 2.4.8
How to fix
Upgrade to a fixed version: Email Log 2.4.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/4621e86e-aba4-429c-8e08-32cf9b4c65e6
- https://wpscan.com/vulnerability/4621e86e-aba4-429c-8e08-32cf9b4c65e6
Get alerted when CVE-2021-24924 or the next vulnerability affects your stack